Discussion:
openvpn 2.4.3 and libressl 2.5 *only*?
(too old to reply)
Harald Dunkel
2017-07-04 07:11:11 UTC
Permalink
Raw Message
Hi folks,

Maybe I was too blind to see, but I'd love to get a tunnel-
blick with the most recent openvpn 2.4.3 and libressl 2.5
included *only*.

Having several choices here (and using the out-of-date
versions by default) appears to be highly confusing to
the road warriors and the least stable configuration in
daily use.


Regards
Harri
Jonathan K. Bullard
2017-07-04 11:02:52 UTC
Permalink
Raw Message
Post by Harald Dunkel
Hi folks,
Maybe I was too blind to see, but I'd love to get a tunnel-
blick with the most recent openvpn 2.4.3 and libressl 2.5
included *only*.
Having several choices here (and using the out-of-date
versions by default) appears to be highly confusing to
the road warriors and the least stable configuration in
daily use.
Hi,

Note: The openvpn-users mailing list is not a good place for comments
or questions about Tunnelblick, which is not part of OpenVPN. Please
use the Tunnelblick Discussion Group [1] or file an Issue on GitHub
[2] instead.

That said, here is my answer to your comment (I'm the Tunnelblick developer):

An official build of Tunnelblick with only the latest version of
OpenVPN and LibreSSL (that is, not including OpenVPN 2.3.x and OpenSSL
1.0.1x) is not likely to happen for several reasons.

You can build your own copy of Tunnelblick with whichever versions you
want [3], or you can set up configurations to always use the latest
Tunnelblick/LibreSSL versions, overriding the default [4]. Or you can
remove undesired versions from official Tunnelblick builds and sign
the resulting build yourself, or you can leave it unsigned (which
might have some undesirable side effects).

Please use the Tunnelblick Discussion Group or a GitHub issue for
further discussion; I won't respond further in this mailing list.

Best regards,

Jon Bullard

[1] https://groups.google.com/forum/#!forum/tunnelblick-discuss

[2] https://github.com/Tunnelblick/Tunnelblick/issues

[3] https://tunnelblick.net/source.html

[4] https://tunnelblick.net/cPkgs.html
Harald Dunkel
2017-07-04 16:19:49 UTC
Permalink
Raw Message
Hi Jon,
sorry for using the wrong mailing list. I highly appreciate your detailed response.
Regards
Harri
Post by Jonathan K. Bullard
Post by Harald Dunkel
Hi folks,
Maybe I was too blind to see, but I'd love to get a tunnel-
blick with the most recent openvpn 2.4.3 and libressl 2.5
included *only*.
Having several choices here (and using the out-of-date
versions by default) appears to be highly confusing to
the road warriors and the least stable configuration in
daily use.
Hi,
Note: The openvpn-users mailing list is not a good place for comments
or questions about Tunnelblick, which is not part of OpenVPN. Please
use the Tunnelblick Discussion Group [1] or file an Issue on GitHub
[2] instead.
An official build of Tunnelblick with only the latest version of
OpenVPN and LibreSSL (that is, not including OpenVPN 2.3.x and OpenSSL
1.0.1x) is not likely to happen for several reasons.
You can build your own copy of Tunnelblick with whichever versions you
want [3], or you can set up configurations to always use the latest
Tunnelblick/LibreSSL versions, overriding the default [4]. Or you can
remove undesired versions from official Tunnelblick builds and sign
the resulting build yourself, or you can leave it unsigned (which
might have some undesirable side effects).
Please use the Tunnelblick Discussion Group or a GitHub issue for
further discussion; I won't respond further in this mailing list.
Best regards,
Jon Bullard
[1] https://groups.google.com/forum/#!forum/tunnelblick-discuss
[2] https://github.com/Tunnelblick/Tunnelblick/issues
[3] https://tunnelblick.net/source.html
[4] https://tunnelblick.net/cPkgs.html
Loading...